This document explains considerations that should be taken into account when planning to install the clients: ROB-EX Scheduler Planner and ROB-EX Scheduler Viewer.

Preparation

First make sure that the target system meets the system requirements. For a client the most important requirement is that a Java Runtime Environment 1.8 or newer is installed.

Determining target installation directory

A ROB-EX Scheduler client (either planner or viewer version) is launched by running a shortcut to the executable file “ROB-EX Gantt.exe”. A ROB-EX Scheduler client do not use any windows registry information, so any PC can in a few minutes be configured to run a ROB-EX Scheduler client.

Viewer clients share the same installer program, but do not share the same execution code. This means that to install both the planner and the viewer client the installation program must be run twice.

Preferrably a single instance of both the planner and viewer software should be installed centrally on a shared file server, e.g. on a network drive like f:\robex\planner and f:\robex\viewer. A central installation will make licensing, managing and upgrading much easier.

A local installation into e.g. c:\program files\ROB-EX\planner is also possible and could be the preferred installation location in the following situations

  • ROB-EX Scheduler demo installations or
  • laptop installation where ROB-EX Scheduler must be launched without network access (users working in “the field”)

Determining what license type to install

Read the chapter Licensing

Connecting clients to ROB-EX Scheduler Multiuser Server

If ROB-EX Scheduler clients are going to be connected to a ROB-EX Scheduler Multiuser Server the following is relevant to note.

ROB-EX Scheduler Multiuser Server is running as a service on a central server in the company. Any ROB-EX Scheduler client with a valid license key opening up the Multiuser connector can connect to the server. Both named licensed and network licensed clients can connect to the Multiuser server.

The only other requirement is that server and client must have the same major version. Version compatibility is automatically checked every time a client connects to the server. In case of incompatibility the user will be warned of the conflict.

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Post Comment